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What is ChessSpider!? 

 

ChessSpider! is an opening repertoire management system, as well as a PGN (Portable Game 

Notation) database manager. Initially the idea was to create a program that easily allowed users to 

keep up to date in their opening systems. It was found that a straightforward solution was not 

forthcoming. Thus the idea of creating a program, which, given any number of positions, could filter 

them out based on the user’s preferred lines, was conceived. This program was personally used to 

great effect as, week after week, PGN games were downloaded, and filtered out repertoire games 

compared to stored lines. Repeating this effortless process periodically and consistently should 

greatly enhance one’s knowledge and confidence in opening theory. 

 

The program’s initial idea was then expanded to the current version 4.2 of ChessSpider!. Simply put, 

a way of opening the resulting filtered files by the program itself (rather than relying on third-party 

software) was very desirable. Thus, the idea came about to create a PGN reader and management 

system. Now, the user can search for games by header data: White/Black/Event/Site, etc. as well as 

by position or Endgame type or a combination of these three search methods. Any valid PGN file can 

be opened, and the limit on the file size or number of games these PGN files may contain depends 

only on the user’s computer’s memory specifications. 

 

Why ChessSpider!? 

 

ChessSpider! has very intuitive, innovative, and fast search algorithms. Game data, positions, and 

endgame types can be searched for alone or combined. Obviously, one cannot fail to mention the 

functionality the program was initially created for! The user can create and maintain files with PGN 

moves (with or without move numbers). Each of these lines represents a position. Users will have a 

file for their “White positions” and another for their “Black positions”. For example, my own White 

and Black repertoires have 150 positions combined. The program can be used on any PGN file, 

whether unannotated or heavily annotated with comments and variations. Searches include the 

variations too. ChessSpider! runs through the file and simultaneously finds the games one is 

interested in. 

One can add and remove positions to any repertoire file. This is extremely easy through the 

Repertoire Manager. Duplicate positions are removed automatically and not allowed within this GUI. 

When replaying games, and a position of interest comes about, hitting a key (or using the 

corresponding menu item) will add this position to the currently open repertoire file. The next 

filtering by White and Black positions will include the positions one adds or removes from their 

repertoire files. 

The user can keep and manage different repertoire files. For example, they can have “solid” White 

and Black repertoire files as well as, for instance, an “aggressive” set of files. Depending on the 

mood they’re in, they can keep up-to-date in their preferred opening lines. 

The principal idea for the program was for users to keep prepped up in their opening lines, and to a 

very high degree of depth. Rather than downloading files manually and running ChessSpider! on 
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them, there is an automatic feature which downloads, decompresses, and filters the latest issue of 

The Week In Chess (https://www.theweekinchess.com). Games from the greats interspersed with 

lesser players can now be at one’s fingertips. 

 

One other very important reason for using ChessSpider! is that it is very inexpensive compared to 

similar programs. ChessSpider!’s motto is indeed “For the price of a book, you get a library!” 

  

https://www.theweekinchess.com/
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The Main Screen 

 

 

Figure 1:The Main Screen 

 

This is the main screen of ChessSpider! 4.2. At the top left, one can see the board, where the games 

can be replayed. The notation panel is at the top right. If the game contains certain characters 

denoting a diagram, an inline diagram is shown alongside the moves.  

 

 

Figure 2: Inline diagrams 

 

This diagram can be rotated by clicking on it. Different depth moves and comments can be seen 

highlighted in different colours. Up to four different nesting of variations are easily visible in 

complicated games. The engine panel sits at the bottom of the notation panel. Positions may be 

analysed and the analysis generated by the included Stockfish engine will be displayed here. The 

analysis is presented in three lines. While the engine is analysing, the user can load different games 

or even PGN files, and the position analysis will follow suit. 

 

The current open PGN file can be seen underneath the engine panel, while the move navigation 
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buttons are below the board. When a position of interest comes about on the board, they may 

simply hit F10 and the position will be added to the currently open Repertoire file (see below). 

 

The games list occupies the bottom half of the screen. One can see various information about each 

game, like, White, Black, their Elo ratings, Date, etc. Of note are the columns Complexity and Text 

which respectively indicate the complexity (total number of half moves, including sub-variations) 

and annotations contained in the games. All columns are sortable by clicking on their headers. Below 

the games list are grid navigation buttons which enable the user to move to the bottom or to the top 

of the list, whilst the other button enables one to clear any applied filter. The user may also enter a 

line number and click on the “Go to line” button (or hit ENTER) and ChessSpider! will jump to that 

line in the grid. 
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Discussion of the Menu Items 

 

File > Open 

 

This presents the user with a dialog where they select a PGN file to open. As mentioned before, 

there is no limitation on how large the PGN file is. Both unannotated games or games containing 

heavy textual comments and variations can be opened by ChessSpider!. These last two criteria can 

be filtered on in fact. 

 

 

Figure 3: Filtering on complexity/text 

 

In this way, the user can find complex or simple games, as well as sparse or highly commented 

games.  
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File > Recent Files 

 

This lists up to 20 PGN files that the user has opened. They are listed in order of when they were 

opened last, so that the most recently opened file sits at the top of the stack of files. 

 

 

Figure 4: Recent file list 

 

File > Exit 

Saves the user’s preferences (including last PGN file loaded, last game and move number viewed) 

and exits the program. 
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Repertoire > Go to Spider! 

 

 

Figure 5: The Spider! window 

 

This opens the Spider! Window. The user opens White and Black text files which denote the 

positions of their repertoire that they are interested in. These are displayed in two columns, one for 

the White repertoire positions, and one for the Black ones. The Black positions are seen from the 

Black perspective. If one wants to exclude some of the positions from the current search, they can 

do so by unchecking the check boxes next to the positions. 

 

They then either open a PGN file and click on the Get Games button, or, alternatively, click on the 

Latest TWIC button, which filters the latest issue of The Week in Chess. In both cases, the respective 

PGN file is filtered by one’s repertoire positions and the original file is suffixed with “_White” and 

“_Black” corresponding to the positions found. 
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Figure 6: The Week in Chess in full and filtered 

 

A prompt is shown to the user where they can open either of the White or Black files produced by 

the program, or view the containing folder in Windows Explorer. 

 

 

Figure 7: Post file-filtering options 

 

One nicety is that if the user opens a black Repertoire file (indicated by the _Black suffix), the games 

are loaded from Black’s perspective of the board. ChessSpider! “remembers” the last files used for 

the White and Black repertoire positions and automatically loads them on subsequent calls of this 

function. An Elo rating constraint can be specified (or left at 0 for all repertoire games to be 
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retrieved) for one or both players, or for their average rating. 

 

Repertoire > Open Repertoire File 

 

This option presents the user with a dialog from which they can select a .txt file containing their 

repertoire positions. Repertoire positions are entered either manually by typing moves in this file 

(for example, e4 c5 Nf3 a6 c4 or 1. d4 d5 2. c4 e6 3. Nc3 c6 4. e4) or added through the user 

interface invoked by the “Manage Repertoire” function, which we will see next. 

 

Repertoire > Manage Repertoire File 

 

 

Figure 8: Manage Repertoire File 

 

If a Repertoire file is opened by users, they can use this menu item to view or edit the positions that 

are contained in the current Repertoire file. The current board position may be added from here 

(and also by hitting F10 in the main screen) and the positions in the user’s file may be removed by 

clicking on any of the board diagrams. These positions reside in the program’s memory, but when 

the user is satisfied with their changes, they can click on the “Save Changes” button, and after 

confirmation their changes will be committed permanently. A FEN (Forsyth-Edwards Notation) 
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encoding of any position may be entered here, and, after clicking “Add to Repertoire” the position is 

rendered on the board. When saving positions to one’s repertoire from this graphical interface, any 

previous positions present in the user’s files will be changed to a hexadecimal representation of the 

positions, with the position saved as 64 characters (one for each square). New positions will be 

saved this way too. 

 

Repertoire > Open and Manage Rep. File 

 

As the name suggests, this function opens and calls the Repertoire Manager in one go. This saves 

time, but it is also useful if the user does not want to add repertoire positions immediately from the 

board positions, and, rather, wants to immediately edit their repertoire positions. 

 

Repertoire > Create Repertoire File 

 

Creates an empty repertoire file. 

 

Repertoire > Copy Repertoire File 

 

This functionality is useful when one wants to copy the currently opened .txt file (representing their 

repertoire positions) into another file. In this way, the originally opened file serves as a template for 

the copied file. 

 

Repertoire > Open Rep. File Location 

 

This is used to open Windows Explorer at the location of the currently open Repertoire file. 
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Game > Filter Games 

 

 

Figure 9: Filter Games by Header data 

 

This is one of the backbones of ChessSpider! in that it allows one to search and filter out games 

based on several criteria. For example, they can enter data like White, Black, Event, Site, Annotator, 

Year, etc. and the system will retrieve the corresponding games. 
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Figure 10: Filter Games by Position 

 

In the second tab the user can enter a position of choice. A FEN position can be entered here, too. 

Otherwise, the user can “pick up” pieces (or the blank square to remove other pieces) and drop 

them on the board where they can construct the required position. The Game button will bring the 

current board position in the main screen to this tab, where it can be searched for together with 

other filter criteria. 
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Figure 11: Filter Games by Endgame 

 

An endgame search may also be run. The most common endgame types are shown and, for 

example, in the above screenshot, the user has selected the notorious opposite-coloured bishops’ 

endgames. 

 

Needless to say, these three search types (Header/Position/Endgame type) may be effectively 

combined so the user can drill down to the necessary games. The filter criteria the user enters, is 

recalled between subsequent visits to the Game Filter. 

 

Game > Load Next Game 

 

Loads the next game in the grid and refreshes the Notation panel with the new moves/annotations. 

 

Game > Load Previous Game 

Like the above, but here ChessSpider! will load the previous game. 

 

  



15 
 

Game > Load Random Game 

 

Quite an interesting function! The program loads the first game whose game number is generated 

randomly. 

 

Game > Get Current ECO 

 

This is another useful function, and it filters the games of the current PGN file based on the ECO of 

the current game. 

 

Game > Get Current White 

 

Similar to the above, but gets the current White player’s games, both with White and Black. 

 

Game > Get Current Black 

Gets the current game’s Black player, and retrieves all the games of this player. 

 

Game > Get Current Event 

 

Searches for the current game’s event in the open PGN file. 

 

Game > Get Current Site 

 

This finds all games where the site of the loaded game is encountered. 
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Game > Games Overview Mode 

 

This menu item, which may also be invoked by clicking on the rightmost icon for any game in the 

games grid (or by conveniently hitting F8) shows the current game summarised in 12 diagrams, 

evenly spaced out according to move number. When the user selects this menu item they enter the 

“Overview mode”, and they can observe the positions of the game, together with highlighted 

squares that led to the positions in question. They can flip all boards by clicking on the relevant icon, 

and they can navigate to previous or next games (in the current data set) while in Overview mode. 

This gives the user the opportunity to quickly skim through the games of interest. Clicking on any of 

the 12 positions will close the Overview window, and load the selected game at the selected 

position. 

 

 
 
Figure 122: Games Overview Mode 

 

 

Game > Export Games 

 

Once the user filters some games, or even the whole PGN file, they can hit this button and the 

games in the grid will be exported to another PGN file of choice. 
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Position > Add to Repertoire File 

 

This menu item takes the current board position and adds it to the open Repertoire file. This process 

can be repeated as many times as the user deems fit, and all the added positions can be found under 

the Repertoire Manager for the open Repertoire File. 

 

Position > Find Position 

 

The current board position is searched for throughout the current PGN file. The process is very fast 

in itself, but when used in conjunction with a header search, it is virtually instant. 

 

 

Figure 13: Find board Position 

 

Position > Rotate Board 

 

Flips the board from White to Black perspective and vice-versa. 
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Position > Toggle Infinite Analysis 

 

Toggles the state of the analysis engine, Stockfish 17.1. The inbuilt engine analyses the board 

position and displays three lines in descending order of evaluation. The engine’s output can be seen 

in the engine panel to the right-hand side of the board. 

 

 

Figure 14: Engine Analysis 
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Moves > Go to Start 

 

Goes to the start of the game. 

 

Moves > Go to End 

 

Skips to the end of the currently loaded game. 

 

Moves > Previous move in line 

 

 

Figure 15: The Notation Panel 

 

This is a useful function, as when a game is heavily annotated, the user can skip all variations of 

different depth (than the current) and just navigate through the moves of the current depth. Moves 

and comments are indented and colour coded in ChessSpider!’s notation panel so the user 

immediately gets an idea of how the game progresses. The current move is highlighted in the panel. 

 

Moves > Next move in line 

 

This allows one to navigate to the next move in the current depth of the game. The same as 

“Previous move in line” applies here too. 

 

Moves > Enter previous variation 

 

This enters the previous move, but irrespective of the depth the user is in. So, for example, if the 

user is in the main line of a game, and there is a variation at the previous move, clicking this menu 

item allows one to go to the previous move, without considering the current depth. This is useful 

when one wants to quickly look at sub-variations contained in the game.  

 

Moves > Enter next variation 

 

Goes to the next move, irrespective of depth. This is similar to the above. 
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Moves > Skip to last variation 

 

Jumps to the start of the previous line in the same depth. 

Moves > Skip to next variation 

 

Skips to the start of the next line in the same depth. 
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Help > Help 

Opens this file! ☺ 

 

Help > About 

 

Displays a popup with a few details about the program. 
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Frequently Asked Questions 

 
How can ChessSpider! help me prepare for my next opponent? 

 

One can easily look at the games of their opponents by using the Header search in the Game filter or 

by hitting F5 and entering the relevant data in the first tab. If players want to find the White games 

of their opponent, they enter their name in the White text box, and alternatively for Black. If they 

want their opponent’s games both as White and as Black (useful for when one wants to analyse their 

opponent’s style of play), they can tick the “Ignore colours” option and the relevant games are 

found. 

 

How do I study games from a particular opening? 

 

If you know the ECO (Encyclopaedia of Chess Openings) code, this can easily be achieved in the 

Header search by utilising the ECO drop down. Here, each code is explained in terms of the name of 

the opening as well as the moves that represent it. This is an accurate way of getting the opening 

games desired although equally good is setting up a position in the Position tab (of the same Game 

Filter) before the branching variations occur, and searching for that position. 

 

One must not forget to mention the Spider! functionality, where whole repertoires can be found at 

the click of one or two buttons. This is especially useful when one wants to keep abreast of new 

developments in their opening systems. 

 

I want to look at Karpov’s handling of Rook and bishop versus Rook and bishop of opposite 

colours. How can I do this? 

 

In the Game Filter, under the White player enter “Karpov” and check the “Ignore Colours” option so 

that both Karpov’s white and black games are obtained. 
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Figure 16: Karpov's Rook and opposite-coloured Bishops’ Endgames (1) 

 

Then, hop over to the “Endgame” tab, and select the eighth option in the leftmost column of 

endgame types. 
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Figure 17: Karpov's Rook and opposite-coloured Bishops’ Endgames (2) 

 

Click on “Search” and these games will be found. Obviously, one presumes that the PGN file opened 

has such games available. 

 

How do I quickly add positions to my Repertoire File? 

 

There are two ways to achieve this. The first way, used in the previous versions of ChessSpider!, is 

simply to enter the moves that lead to the position of interest in any text file (.txt). So, for example, 

one may enter the moves: 

 

1. e4 c6 2. d4 d5 3. exd5 cxd5 4. c4 for the Caro-Kann Panov-Botvinnik System (this is obviously a 

simplified example). Move numbers may or may not be omitted. 
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Figure 18: One way of entering positions in a Repertoire File 

 

The second way is to add positions from games. Say, one is looking at a game and they find a 

position which interests them, they can simply hit F10 (or if they prefer, use the relevant menu item) 

and it will be added to the current Repertoire File. 

 

Can I copy one of my Repertoire files through the program, and amend it without affecting the 

original file? 

 

Yes, this is very easily done. One opens the source Repertoire File through the menu Repertoire > 

Open Repertoire File, then clicks on Repertoire > Copy Repertoire File. ChessSpider! asks for a 

destination file name, and the original file will be copied to the destination. New changes will not 

affect the original file. 

 

I am looking at a game and I find the opening particularly interesting. How can I quickly get similar 

games of the same opening? 

 

This can be achieved by clicking the menu item Game > Get Current ECO, and the ECO games which 

match the current ECO will be displayed. 

 

All these cases obviously assume that one has a PGN file which contains such games that the user 

wants to find! 

 

I have just filtered out 150 games from a large PGN file, and I do not want to lose them when I 

close the program. Can I somehow maintain them permanently? 

 

One can use the Game > Export games functionality and the games currently present in the games 

list are exported to a new PGN file selected by the user. The newly exported file may then be opened 

separately, and the original search results are maintained. 
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I was casually looking through the game Kasparov – Shirov, from Horgen 1994, and I was intrigued 

by Kasparov’s exchange sacrifice on move 17. I wanted to see if the position before 17. Rxb7 had 

occurred before, or if it has occurred ever since. Is this possible to do? 

 

If one navigates to the position before 17. Rxb7 and clicks on the “lens” icon underneath the board 

(or uses the menu Position > Find Position or hits F12), such games in the PGN file currently open will 

be found, if any. 

 

 

Figure 19: Kasparov - Shirov, Horgen, 1994. Position before 17. Rxb7 

 

Where are the downloaded TWICs located? 

 

Any weekly updates from The Week in Chess are downloaded in full and filtered out in the Data 

folder relative to the program’s path. One can also find there a free PGN file of the complete games 

of all World Champions from the first unofficial World Champion, Paul Morphy, to the 13th World 

Champion, Garry Kasparov. This is the default file which is opened when ChessSpider! is run the first 

time. 
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Useful keyboard shortcuts 
 

File > Open CTRL + O 

File > Exit ALT + F4 

 

Repertoire > Go to Spider! CTRL + S 

Repertoire > Open Repertoire File CTRL + R 

Repertoire > Manage Repertoire File CTRL + M 

Repertoire > Open and Manage Rep. File CTRL + ALT + M 

Repertoire > Create Repertoire File Insert 

Repertoire > Copy Repertoire File CTRL + C 

Repertoire > Open Rep. File Location CTRL + L 

 

Game > Filter Games F5 

Game > Load Next Game F7 

Game > Load Previous Game F6 

Game > Load Random Game CTRL + ALT + R 

Game > Get Current ECO CTRL + ALT + E 

Game > Get Current White CTRL + ALT + W 

Game > Get Current Black CTRL + ALT + B 

Game > Get Current Event CTRL + ALT + V 

Game > Get Current Site CTRL + ALT + S 

Game > Games Overview Mode F8 

Game > Export Games ALT + E 

 

Position > Add to Repertoire File F10 

Position > Find Position F12 

Position > Rotate Board CTRL + F 

Position > Toggle Infinite Analysis CTRL + ALT + A 

 

Go to Start Home 

Go to End End 

Previous move in line Left 

Next move in line Right 

Enter previous variation Up 

Enter next variation Down 

Skip to last variation Page up 

Skip to next variation Page down 

 

Go to line (after entering line number) ENTER 

Clear current search criteria ESC 

 


